Publican exploit para bug (parcheado) en Safari

Packet Storm ha publicado hoy un exploit para una vulnerabilidad conocida (y parcheada) de desbordamiento de búfer en el navegador Safari de Apple.
Afecta a la versión 6.0.1 de iOS 6 y OS X 10.7/8 y posiblemente anteriores y sus detalles fueron facilitados por el investigador de seguridad independiente Vitaliy Toropov a través de su programa de recompensas de Packet Storm.

En concreto el desbordamiento de pila existe en el método JavaScriptCore JSArray::sort(...) del WebKit. Este método acepta funciones Javascript y llamadas definidas por el usuario y compara arrays. Si esta función de comparación reduce la longitud de array, entonces los elementos del array restantes serán escritos fuera del buffer "m_storage>-m_vector[]", lo que conduce a la corrupción de la pila de la memoria.

Tenéis una prueba de concepto del exploit al completo en: http://packetstormsecurity.com/files/123088/, que demuestra como usar su código Javascript para corromper la memoria de objetos JS (Unit32Array, etc.) y la posterior ejecución de código arbitrario (es posible pegar payloads ARM/x64 personalizados en el código JS).

Por supuesto, recordaros que los exploits de vulnerabilidades conocidas e incluso parcheadas son mucho más utilizados por los desarrolladores de malware y exploit kits que los zero days, simplemente por lo de siempre: son muchísimos los clientes desactualizados...

Fuente: http://packetstormsecurity.com/files/123089/Packet-Storm-Advisory-2013-0903-1-Apple-Safari-Heap-Buffer-Overflow.html

0 comentarios :

Publicar un comentario en la entrada