Liberado Metasploit Framework 3.5.2


Ya tenemos disponible una nueva versión de nuestro Framework de Pentesting por excelencia.

Esta nueva versión corrige una vulnerabilidad de escalada de privilegios descubierta en las instalaciones multiusuario en Windows la cuál fué notificada el pasado 1 de Febrero por Eduardo Prado de
Secumania.

El problema era debido a los permisos heredados que permiten a un usuario sin privilegios escribir archivos en el directorio de instalación de
Metasploit.

La nueva versión corrige esto último a través de dos cambios:

- Se ha movido la instalación por defecto a %ProgramFiles% con lo cuál se evita que un usuario sin privilegios pueda escribir.


- Se ha eliminado de manera explícita los permisos heredados de los grupos "Usuarios" y "Usuarios autenticados".

También, si prefieres no volver a instalar Metasploit, puedes solucionar el problema usando los siguientes comandos:

- Para sistemas posteriores a Windows Vista:

icacls c:\framework /inheritance:d /t
icacls c:\framework /remove *S-1-5-32-545 /t
icacls c:\framework /remove *S-1-5-11 /t


- Para sistemas anteriores a Vista, necesitarás la herramienta xcacls.vbs disponible en Microsoft

xcacls.vbs c:\framework /E /R SID#S-1-5-32-545 /T

En dichos sistemas no sería necesario eliminar los permisos para el grupo "Usuarios autenticados" puesto que no exíste.

Por último, en esta versión 3.5.2 además de solucionar esta vulnerabilidad se corrigen más de 50 bugs y contiene 39 módulos nuevos.

Ya podéis descargar esta versión desde la página oficial de Metasploit:

http://www.metasploit.com/framework/download/

0 comentarios :

Publicar un comentario en la entrada