Liberan el exploit "dlclose" para correr Linux en la PS4

Hace unos meses en la 32c3 (la CON de CCC en Alemania) el grupo Fail0verflow demostró que podía ejecutar Linux en la PS4 y publicó un loader. Eso sí, se reservó el exploit utilizado para evitar posibles represarias o demandas de Sony como la que le hicieron a Geohot por la PS3. 

A partir de ahí se inició una carrera de investigación en la que CTurt parece volver a estar activo y haciendo progresos. Especialmente con una vulnerabilidad de desbordamiento de pila en el kernel en la llamada al sistema con sys_dynlib_prepare_dlclose que como se hizo con el exploit BadIRET fue parcheada, concretamente en el firmware 2.00. Se trata del conocido como exploit dlclose cuyo funcionamiento fue confirmado por el popular bigboss (@psxdev).

Ya a la vuelta de la esquina, hace algo más de una semana, Zer0xFF publicó el código de un exploit dlclose para la versión 1.76 de firmware que sin embargo crasheaba cuando el exploit intentaba volver a userland. Sin embargo y sólo hace unos días el chileno Carlos Pizarro alias kR105 lo corrigió incluyendo el escalado de privilegios como root, la evasión del sandbox y el jailbreak. Además para usar Linux en la PS4 sin tener que escribir un loader también pone a disposición de cualquiera el fichero bzImage y initramfs.cpio.gz "...para conseguirte linux con un agradable bash en tu tv".

El código completamente funcional lo tenéis en github y puede compilarse mediante el SDK de CTurf. Tener en cuenta que no se trata de un CFW para poder usar juegos pirateados, pero si una "puerta abierta" para todo aquel que pueda quiera trastear y, aunque este exploit sólo funcionará sólo con firmware 1.76 antiguos (del 20 de agosto de 2014) todavía es posible comprar alguna consola. Si conseguís alguna tenéis dos métodos para usarlo:

dlclose exploit for PS4 fw 1.76: https://github.com/kR105/PS4-dlclose

0 comentarios :

Publicar un comentario en la entrada